Cover image for Making Sense of Syntax

Making Sense of Syntax

laurieontech profile image Laurie Originally published at laurieontech.com ・2 min read

I was reviewing a bit of code the other day and came across a set of syntax I hadn't seen before. It looked like this:

!!{...obj, ...obj2}.item

There are pieces of this code I recognize. But all together? Not so much.

Object Spread

If we go by order of operations the first thing we need to look at is the spread piece of this expression.

{...obj, ...obj2}

Luckily I've written that post before. It's taking two objects and creating a single object with all the unique key value pairs between them.

What comes next?

This was the first thing I needed to figure out. I was pretty confident the next piece of syntax to execute was the .item selector, but I wasn't positive.

Turns out that is correct. Since the result of our spread expression is an object, we're accessing the value of the item key in that object.

To break it down we can write it this way.

const newObj = {...obj, ...obj2}
const item = newObj.item

Bang Bang

This may be the most unfamiliar bit of syntax. ! means NOT in JavaScript, but was does !! mean? It actually means NOT NOT. It's guaranteeing that the result of the expression is always true or false.

I found this article to be the best explanation but I'll try to summarize here.

In JavaScript we have falsy values and truthy values. null, for example, is falsy. That means this statement is true.

!null === true

If we add another ! we discover the expression is equivalent to false.

!!null === false

So !! is telling us whether our expression is truthy or falsy.

All together

Let's look at our original example.

!!{...obj, ...obj2}.item

If we break it down it's doing this.

const newObj = {...obj, ...obj2}
const item = newObj.item
if (item) {
    return true
} else {
    return false

The result depends entirely on our objects. Let's look at two options.

Example 1:

const obj = {
    item: null
const obj2 = {
    key: "thing"

In this case, the expression is false, because null is falsy.

Example 2:

const obj = {
    key: false
const obj2 = {
    item: "some value"

In this example, the expression is true! "some value" is truthy.

Pretty cool

What do you think? Not sure how often I'd use it, but it's a neat bit of code. Allows us to look through a number of objects and determine if we have a legitimate value for a particular key.

Posted on by:

laurieontech profile



Software dev at Gatsby | DC techie | Conference speaker | egghead Instructor | TC39 Educators Committee | Girls Who Code Facilitator | Board game geek | @laurieontech on twitter


markdown guide

3 lines of clear code > 1 line of cryptic code


I wrote the code that Laurie reviewed, and I do agree with everyone criticising it. The spreads in particular are very inefficient. In my defense, perhaps I should explain what the code was actually doing. The real obj1 and obj2 were actually packageJson.devDependencies and packageJson.dependencies, and originally I had been creating a combined list of dependencies, which I was then using elsewhere. When I simplified it into a single check, I didn't then also refactor out the spread. But that's what code reviews are for! The version that I ended up committing was something like:

function isGatsbySite(packageJson) {
    return !!(packageJson.dependencies?.gatsby || packageJson.devDependencies?.gatsby)

...except it was actually TypeScript. The !! was because the return value was a boolean. I supposed I could've used a Boolean cast there. πŸ€·β€β™‚οΈ


Thanks for the answer, nice to know the "behind the scenes" πŸ˜„
I think in another comment Sebastian mentioned that depending on the target audience of the code, it may or may not be relevant to use some code conventions.
Personally when I see "!!" I know what it means but the first time I encountered it I was really puzzled πŸ™‚
But again, context is everything. In this case, I'd say that the fact that the function is named "isGatsbySite" is more than enough to clarify the code.


I’d argue that it was a reasonable way of doing it. Was there a way to simplify it? Sure. But it wasn’t egregious. Plus, I learned something :)


Now that you have explained it I might use it for personal code but I definitely wouldn't have easily recognized what was going on without this explanation. Soo depending on the team I am working with I might not use it if I think it would confuse others on my team.


While I prefer readable code, I also know that "readable" is in the eye of the beholder.
Someone who is very familiar with such advanced JS syntax will find

!!{...obj, ...obj2}.item

absolutely readable. Others not so much.
If the target audience of my code is people among the first group, I'd use it. Otherwise, not so much.

Trade offs as usual πŸ€ͺ


I have really started to prefer functions to provide clarity:

    merge(obj, obj2)

What's powerful here is if this is common place, make a helper!

const eitherHasItem = (a, b) =>
  isTruthy(pluck('item', merge(a, b)));

eitherHasItem(obj, obj2); //true|false

!!x is just a less readable version of x != false.

{...a, ...b }.c is just a less efficient version of b.c ll a.c.



const a = { c: 42 }
const b = { c : 0 }

const x1 = !!{...a, ...b}.c // false
const x2 = !!{...b, ...a}.c // true
const x3 = b.c || a.c // 42
const x4 = a.c || b.c // 42

Fair point -- although to really answer this we need to understand what the original code is trying to achieve to see what the actual problem domain is.

b.c ?? a.c might be sufficient, depending on how you want to deal with nullish values.

('c' in b ? b.c : a.c) might also do.

But whatever you're trying to do, it's unlikely that merging two objects to look up a property is the most reasonable option. :)

we need to understand what the original code is trying to achieve

This is what the code should describe (not just to you - but to your average programmer)

I don't think that's a reasonable expectation.

The code will describe the what and the how, but I have yet to see a programming language which encapsulates the why of it.

If your argument is that it should contain comments which explain why this is being done, then I agree.

In which case, I guess your point is that the snippet provided is defective because it lacks this. :)


Somehow this 1 line of code is in fact 50 lines, because it requires explanatory article :-) Readable > Pretty cool.


I personally use it all the time now that I've been using typescript. This makes perfect sense.


I'll start using it for sure, it seems a good way to assert you are dealing with the right type in JS. Thanks for the article.


Boolean({...x,...y}.item) does the same thing, and I prefer it because the intent is more clear at a glance.