If a name is already used, we can always prefix it with 'the'.
TL;DR: don't prefix your variables.
Use intention revealing names.
Avoid Indistinct noise words.
var result; result = getSomeResult(); var theResult; theResult = getSomeResult();
var averageSalary; averageSalary = calculateAverageSalary(); //.. var averageSalaryWithRaises; averageSalaryWithRaises = calculateAverageSalary();
As with many of our naming conventions, we can instruct our linters to forbid names like theXxx....
Always use intention revealing names.
If your names collide use local names, extract your methods and avoid 'the' prefixes.
One difference between a smart programmer and a professional programmer is that the professional understands that clarity is king. Professionals use their powers for good and write code that others can understand.
Robert C. Martin
This article is part of the CodeSmell Series.